What’s Vulnerable › Vulnerabilities
CVE-2024-8911: LatePoint <= 5.0.11 - Unauthenticated Arbitrary User Password Change via SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-08 · updated 2026-06-17
- Weakness: CWE-89
Description
The LatePoint plugin for WordPress is vulnerable to Arbitrary User Password Change via SQL Injection in versions up to, and including, 5.0.11. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to change user passwords and potentially take over administrator accounts. Note that changing a WordPress user's password is only possible if the "Use WordPress users as customers" setting is enabled, which is disabled by default. Without this setting enabled, only the passwords of plugin customers, which are stored and managed in a separate database table, can be modified.
Affected products
- LatePoint: before 5.0.12 — fixed in 5.0.12
How to fix
Upgrade to a fixed version: LatePoint 5.0.12. Check the vendor advisory for mitigations.
References
- https://wpdocs.latepoint.com/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5c9a23a3-5eb5-4f5b-bf32-c9d163426f29?source=cve
Get alerted when CVE-2024-8911 or the next vulnerability affects your stack