What’s Vulnerable › Vulnerabilities
CVE-2024-8912: HTTP Request Smuggling in Looker
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-11 · updated 2026-06-17
- Weakness: CWE-444
Description
An HTTP Request Smuggling vulnerability in Looker allowed an unauthorized attacker to capture HTTP responses destined for legitimate users. There are two Looker versions that are hosted by Looker: * Looker (Google Cloud core) was found to be vulnerable. This issue has already been mitigated and our investigation has found no signs of exploitation. * Looker (original) was not vulnerable to this issue. Customer-hosted Looker instances were found to be vulnerable and must be upgraded. This vulnerability has been patched in all supported versions of customer-hosted Looker, which are available on the Looker download page https://download.looker.com/ . For Looker customer-hosted instances, please update to the latest supported version of Looker as soon as possible. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page: * 23.12 -> 23.12.123+ * 23.18 -> 23.18.117+ * 24.0 -> 24.0.92+ * 24.6 -> 24.6.77+ * 24.8 -> 24.8.66+ * 24.10 -> 24.10.78+ * 24.12 -> 24.12.56+ * 24.14 -> 24.14.37+
Affected products
- Google Looker: from 23.12 before 23.12.123; from 23.18 before 23.18.117; from 24.0 before 24.0.92; from 24.6 before 24.6.77; from 24.8 before 24.8.66; from 24.10 before 24.10.78 — fixed in 23.12.123, 23.18.117, 24.0.92, 24.10.78, 24.12.56, 24.14.37
How to fix
Upgrade to a fixed version: Google Looker 23.12.123, 23.18.117, 24.0.92, 24.10.78. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8912 or the next vulnerability affects your stack