What’s Vulnerable › Vulnerabilities
CVE-2024-8922: Product Enquiry for WooCommerce <= 2.2.33.33 - Authenticated (Author+) PHP Object Injection in enquiry_detail.php
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-502
Description
The Product Enquiry for WooCommerce, WooCommerce product catalog plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.2.33.32 via deserialization of untrusted input in enquiry_detail.php. This makes it possible for authenticated attackers, with Author-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- PI Websolution Product Enquiry for WooCommerce, WooCommerce product catalog: before 2.2.33.34 — fixed in 2.2.33.34
How to fix
Upgrade to a fixed version: PI Websolution Product Enquiry for WooCommerce, WooCommerce product catalog 2.2.33.34. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3155863/enquiry-quotation-for-woocommerce
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9a485314-cd68-400c-b398-2f8529c6a3ab?source=cve
Get alerted when CVE-2024-8922 or the next vulnerability affects your stack