What’s Vulnerable › Vulnerabilities

CVE-2024-8925: Erroneous parsing of multipart form data

Description

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, erroneous parsing of multipart form data contained in an HTTP POST request could lead to legitimate data not being processed. This could lead to malicious attacker able to control part of the submitted data being able to exclude portion of other data, potentially leading to erroneous application behavior.

Affected products

How to fix

Upgrade to a fixed version: PHP 8.1.30, 8.2.24, 8.3.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8925 or the next vulnerability affects your stack