What’s Vulnerable › Vulnerabilities

CVE-2024-8929: Leak partial content of the heap through heap buffer over-read in mysqlnd

Description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, a hostile MySQL server can cause the client to disclose the content of its heap containing data from other SQL requests and possible other data belonging to different users of the same server.

Affected products

How to fix

Upgrade to a fixed version: PHP 8.1.31, 8.2.26, 8.3.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8929 or the next vulnerability affects your stack