What’s Vulnerable › Vulnerabilities

CVE-2024-8932: OOB access in ldap_escape

Description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, uncontrolled long string inputs to ldap_escape() function on 32-bit systems can cause an integer overflow, resulting in an out-of-bounds write.

Affected products

How to fix

Upgrade to a fixed version: PHP 8.1.31, 8.2.26, 8.3.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8932 or the next vulnerability affects your stack