What’s Vulnerable › Vulnerabilities
CVE-2024-8957: PTZOptics PT30X-SDI/NDI Cameras OS Command Injection Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-11-04
- EPSS: 79.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-78
Description
PTZOptics PT30X-SDI/NDI-xx before firmware 6.3.40 is vulnerable to an OS command injection issue. The camera does not sufficiently validate the ntp_addr configuration value which may lead to arbitrary command execution when ntp_client is started. When chained with CVE-2024-8956, a remote and unauthenticated attacker can execute arbitrary OS commands on affected devices.
Affected products
- PTZOptics Pt30X-Ndi-Xx-G2 Firmware: before 6.3.40 — fixed in 6.3.40
- PTZOptics Pt30X-Sdi Firmware: before 6.3.40 — fixed in 6.3.40
How to fix
Upgrade to a fixed version: PTZOptics Pt30X-Ndi-Xx-G2 Firmware 6.3.40; PTZOptics Pt30X-Sdi Firmware 6.3.40. Check the vendor advisory for mitigations.
References
- https://ptzoptics.com/firmware-changelog/
- https://vulncheck.com/advisories/ptzoptics-command-injection
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-8957
- https://www.greynoise.io/blog/greynoise-intelligence-discovers-zero-day-vulnerabilities-in-live-streaming-cameras-with-the-help-of-ai
- https://www.labs.greynoise.io/grimoire/2024-10-31-sift-0-day-rce/
Get alerted when CVE-2024-8957 or the next vulnerability affects your stack