What’s Vulnerable › Vulnerabilities
CVE-2024-8962: WPBITS Addons For Elementor Page Builder <= 1.5.2 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPBITS Addons For Elementor Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- WPBITS Addons For Elementor Page Builder: before 1.6 — fixed in 1.6
How to fix
Upgrade to a fixed version: WPBITS Addons For Elementor Page Builder 1.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpbits-addons-for-elementor/trunk/includes/elementor-config.php#L721
- https://plugins.trac.wordpress.org/changeset/3200392/
- https://wordpress.org/plugins/wpbits-addons-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f735f05d-8178-46bd-894d-49ccfb31d304?source=cve
Get alerted when CVE-2024-8962 or the next vulnerability affects your stack