What’s Vulnerable › Vulnerabilities
CVE-2024-8965: Absolute Reviews <= 1.1.3 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via Criteria Name
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Absolute Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Name' field of a custom post criteria in all versions up to, and including, 1.1.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Code Supply Co. Absolute Reviews: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: Code Supply Co. Absolute Reviews 1.1.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3156409/absolute-reviews
- https://www.wordfence.com/threat-intel/vulnerabilities/id/12cfebb8-ae89-410b-a492-340f1553e83e?source=cve
Get alerted when CVE-2024-8965 or the next vulnerability affects your stack