What’s Vulnerable › Vulnerabilities
CVE-2024-8967: PWA — easy way to Progressive Web App <= 1.6.3 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The PWA — easy way to Progressive Web App plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.6.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- iworks PWA — easy way to Progressive Web App: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: iworks PWA — easy way to Progressive Web App 1.6.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/iworks-pwa/trunk/includes/iworks/class-iworks-svg.php#L16
- https://plugins.trac.wordpress.org/changeset/3161056/
- https://wordpress.org/plugins/iworks-pwa/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/000bf956-1781-4596-ac12-81691fdd789c?source=cve
Get alerted when CVE-2024-8967 or the next vulnerability affects your stack