What’s Vulnerable › Vulnerabilities
CVE-2024-8968: MaxButtons < 9.8.1 - Admin+ Stored XSS via Text Color
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress Button Plugin MaxButtons WordPress plugin before 9.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- maxfoundry MaxButtons – Create buttons: before 9.8.1 — fixed in 9.8.1
How to fix
Upgrade to a fixed version: maxfoundry MaxButtons – Create buttons 9.8.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8968 or the next vulnerability affects your stack