What’s Vulnerable › Vulnerabilities

CVE-2024-8970: Incorrect Authorization in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 11.6 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows an attacker to trigger a pipeline as another user under certain circumstances.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.2.9, 17.3.5, 17.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8970 or the next vulnerability affects your stack