What’s Vulnerable › Vulnerabilities
CVE-2024-8974: Incorrect Provision of Specified Functionality in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-684
Description
Information disclosure in Gitlab EE/CE affecting all versions from 15.6 prior to 17.2.8, 17.3 prior to 17.3.4, and 17.4 prior to 17.4.1 in specific conditions it was possible to disclose to an unauthorised user the path of a private project."
Affected products
- GitLab: from 15.6.0 before 17.2.8; from 17.3.0 before 17.3.4; 17.4.0 — fixed in 17.2.8, 17.3.4
How to fix
Upgrade to a fixed version: GitLab 17.2.8, 17.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8974 or the next vulnerability affects your stack