What’s Vulnerable › Vulnerabilities

CVE-2024-8977: Server-Side Request Forgery (SSRF) in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 15.10 prior to 17.2.9, from 17.3 prior to 17.3.5, and from 17.4 prior to 17.4.2. Instances with Product Analytics Dashboard configured and enabled could be vulnerable to SSRF attacks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.2.9, 17.3.5, 17.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8977 or the next vulnerability affects your stack