What’s Vulnerable › Vulnerabilities

CVE-2024-8980

Description

The Script Console in Liferay Portal 7.0.0 through 7.4.3.101, and Liferay DXP 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, 7.2 GA through fix pack 20, 7.1 GA through fix pack 28, 7.0 GA through fix pack 102 and 6.2 GA through fix pack 173 does not sufficiently protect against Cross-Site Request Forgery (CSRF) attacks, which allows remote attackers to execute arbitrary Groovy script via a crafted URL or a XSS vulnerability.

Affected products

How to fix

Upgrade to a fixed version: Liferay Digital Experience Platform 2023.q3.5; Liferay Portal 7.0.6, 7.1.3, 7.4.3.102. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8980 or the next vulnerability affects your stack