What’s Vulnerable › Vulnerabilities
CVE-2024-8984: Denial of Service (DoS) in berriai/litellm
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-770
Description
A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. This vulnerability can be exploited by appending characters, such as dashes (-), to the end of a multipart boundary in an HTTP request. The server continuously processes each character, leading to excessive resource consumption and rendering the service unavailable. The issue is unauthenticated and does not require any user interaction, impacting all users of the service.
Affected products
- BerriAI litellm: before 1.65.4; 1.65.4-dev2, 1.65.4-dev6, 1.65.4-dev8, 1.65.4-nightly — fixed in 1.65.4
How to fix
Upgrade to a fixed version: BerriAI litellm 1.65.4. Check the vendor advisory for mitigations.
References
- https://github.com/berriai/litellm/commit/4f49f836aa844ac9b6bfbeff27e6f6b2b9cf3f61
- https://huntr.com/bounties/554fc76b-3097-4223-b4cf-110b853e9355
Get alerted when CVE-2024-8984 or the next vulnerability affects your stack