What’s Vulnerable › Vulnerabilities
CVE-2024-8991: OSM <= 6.1.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via osm_map and osm_map_v3 Shortcodes
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The OSM – OpenStreetMap plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's osm_map and osm_map_v3 shortcodes in all versions up to, and including, 6.1.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- photoweblog OSM – OpenStreetMap: before 6.1.1 — fixed in 6.1.1
How to fix
Upgrade to a fixed version: photoweblog OSM – OpenStreetMap 6.1.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/osm/trunk/osm-metabox.php#L155
- https://plugins.trac.wordpress.org/browser/osm/trunk/osm-metabox_v4.php#L139
- https://plugins.trac.wordpress.org/browser/osm/trunk/osm.php#L1120
- https://plugins.trac.wordpress.org/changeset/3157069/
- https://wordpress.org/plugins/osm/#developers
- https://wp-osm-plugin.hyumika.com/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/839ecd06-9c74-4ddc-b455-26ec3e627889?source=cve
Get alerted when CVE-2024-8991 or the next vulnerability affects your stack