What’s Vulnerable › Vulnerabilities
CVE-2024-8999: Improper Access Control in lunary-ai/lunary
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-862
Description
lunary-ai/lunary version v1.4.25 contains an improper access control vulnerability in the POST /api/v1/data-warehouse/bigquery endpoint. This vulnerability allows any user to export the entire database data by creating a stream to Google BigQuery without proper authentication or authorization. The issue is fixed in version 1.4.26.
Affected products
- lunary-ai/lunary: before 1.4.26 — fixed in 1.4.26
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.26. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/aa0fd22952d1d84a717ae563eb1ab564d94a9e2b
- https://huntr.com/bounties/d42b7a44-0dcb-4ef0-b15c-d0e558da65c6
Get alerted when CVE-2024-8999 or the next vulnerability affects your stack