What’s Vulnerable › Vulnerabilities
CVE-2024-9014: OAuth2 client id and secret exposed through the web browser in pgAdmin 4
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-23 · updated 2026-06-17
- Weakness: CWE-522
Description
pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.
Affected products
- pgadmin.org pgAdmin 4: before 8.12 — fixed in 8.12
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 8.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9014 or the next vulnerability affects your stack