What’s Vulnerable › Vulnerabilities
CVE-2024-9020: List category posts < 0.90.3 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The List category posts WordPress plugin before 0.90.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- fernandobt List category posts: before 0.90.3 — fixed in 0.90.3
How to fix
Upgrade to a fixed version: fernandobt List category posts 0.90.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9020 or the next vulnerability affects your stack