What’s Vulnerable › Vulnerabilities
CVE-2024-9022: TS Poll – Survey, Versus Poll, Image Poll, Video Poll <= 2.4.0 - Authenticated (Administrator+) SQL Injection via orderby Parameter
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-89
Description
The TS Poll – Survey, Versus Poll, Image Poll, Video Poll plugin for WordPress is vulnerable to SQL Injection via the ‘orderby’ parameter in all versions up to, and including, 2.4.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- totalsoft TS Poll: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: totalsoft TS Poll 2.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/capture0x/Poll-Plugin-SQL-Injection-
- https://packetstormsecurity.com/files/179414/WordPress-Poll-2.3.6-SQL-Injection.html
- https://plugins.trac.wordpress.org/changeset/3157008/poll-wp/tags/2.4.0/admin/class-ts_poll_list.php?old=3144592&old_path=poll-wp%2Ftags%2F2.3.9%2Fadmin%2Fclass-ts_poll_list.php
- https://plugins.trac.wordpress.org/changeset/3165098/poll-wp/tags/2.4.1/admin/class-ts_poll_list.php?old=3157008&old_path=poll-wp%2Ftags%2F2.4.0%2Fadmin%2Fclass-ts_poll_list.php
- https://total-soft.com/wp-poll/
- https://wordpress.org/plugins/poll-wp/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d16363d6-ca4b-4de0-abae-a7b07803e2e3?source=cve
Get alerted when CVE-2024-9022 or the next vulnerability affects your stack