What’s Vulnerable › Vulnerabilities
CVE-2024-9025: Sight – Professional Image Gallery and Portfolio <= 1.1.2 - Missing Authorization to Sensitive Information Exposure in handler_post_title
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-862
Description
The Sight – Professional Image Gallery and Portfolio plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'handler_post_title' function in all versions up to, and including, 1.1.2. This makes it possible for unauthenticated attackers to expose private, pending, trashed, and draft post titles. Successful exploitation requires the Elementor plugin to be installed and activated.
Affected products
- codesupplyco Sight – Professional Image Gallery and Portfolio: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: codesupplyco Sight – Professional Image Gallery and Portfolio 1.1.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3156405/sight
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f889342e-03fb-44eb-b5cb-acf115a526c3?source=cve
Get alerted when CVE-2024-9025 or the next vulnerability affects your stack