What’s Vulnerable › Vulnerabilities

CVE-2024-9047: WordPress File Upload <= 4.24.11 - Unauthenticated Path Traversal to Arbitrary File Read and Deletion in wfu_file_downloader.php

Description

The WordPress File Upload plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 4.24.11 via wfu_file_downloader.php. This makes it possible for unauthenticated attackers to read or delete files outside of the originally intended directory. Successful exploitation requires the targeted WordPress installation to be using PHP 7.4 or earlier.

Affected products

How to fix

Upgrade to a fixed version: nickboss Iptanus File Upload 4.24.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-9047 or the next vulnerability affects your stack