What’s Vulnerable › Vulnerabilities
CVE-2024-9061: WP Popup Builder – Popup Forms and Marketing Lead Generation <= 1.3.5 - Unauthenticated Arbitrary Shortcode Execution via wp_ajax_nopriv_shortcode_Api_Add
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 52.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-94
Description
The The WP Popup Builder – Popup Forms and Marketing Lead Generation plugin for WordPress is vulnerable to arbitrary shortcode execution via the wp_ajax_nopriv_shortcode_Api_Add AJAX action in all versions up to, and including, 1.3.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. NOTE: This vulnerability was partially fixed in version 1.3.5 with a nonce check, which effectively prevented access to the affected function. However, version 1.3.6 incorporates the correct authorization check to prevent unauthorized access.
Affected products
- WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter: before 1.3.6 — fixed in 1.3.6
How to fix
Upgrade to a fixed version: WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter 1.3.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3166506/wp-popup-builder
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0cac1dc0-87dc-43eb-9db1-638a91200b43?source=cve
Get alerted when CVE-2024-9061 or the next vulnerability affects your stack