What’s Vulnerable › Vulnerabilities
CVE-2024-9075: Stirling-Tools Stirling-PDF Markdown-to-PDF cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-21 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Stirling-Tools Stirling-PDF up to 0.28.3. It has been declared as problematic. This vulnerability affects unknown code of the component Markdown-to-PDF. The manipulation leads to cross site scripting. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.29.0 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains that "this functionality was removed in 0.29.0 already" and "we plan to re-add at later date with issue resolved".
Affected products
- Stirling-Tools Stirling-PDF: before 0.29.0 — fixed in 0.29.0
How to fix
Upgrade to a fixed version: Stirling-Tools Stirling-PDF 0.29.0. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1J4TnzgzKOEvMck3kpaFuR6zfSVt7YgKu/view?usp=sharing
- https://vuldb.com/?ctiid.278242
- https://vuldb.com/?id.278242
- https://vuldb.com/?submit.406335
Get alerted when CVE-2024-9075 or the next vulnerability affects your stack