What’s Vulnerable › Vulnerabilities
CVE-2024-9098: Privilege Escalation in lunary-ai/lunary
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-863
Description
In lunary-ai/lunary before version 1.4.30, a privilege escalation vulnerability exists where admins can invite new members with billing permissions, thereby gaining unauthorized access to billing resources. This issue arises because the user creation endpoint does not restrict admins from inviting users with billing roles. As a result, admins can circumvent the intended access control, posing a risk to the organization's financial resources.
Affected products
- lunary-ai/lunary: before 1.4.30 — fixed in 1.4.30
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.30. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/a8d7b2959e87c30fbafdb12af7ffa093385dcc60
- https://huntr.com/bounties/75d466ae-8591-44d5-9160-eea7cad0c4fc
Get alerted when CVE-2024-9098 or the next vulnerability affects your stack