What’s Vulnerable › Vulnerabilities
CVE-2024-9129: Format String Injection in Zend Server
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-134
Description
In versions of Zend Server 8.5 and prior to version 9.2 a format string injection was discovered. Reported by Dylan Marino
Affected products
- Zend Server: from 8.5 before 9.1 — fixed in 9.1
How to fix
Upgrade to a fixed version: Zend Server 9.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9129 or the next vulnerability affects your stack