What’s Vulnerable › Vulnerabilities
CVE-2024-9148: Flowise Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.
Affected products
- FlowiseAI Embed: before 2.0.0 — fixed in 2.0.0
- FlowiseAI Flowise: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: FlowiseAI Embed 2.0.0; FlowiseAI Flowise 2.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9148 or the next vulnerability affects your stack