What’s Vulnerable › Vulnerabilities
CVE-2024-9150: Code Injection in Wyn Enterprise
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-1336
Description
Report generation functionality in Wyn Enterprise allows for code inclusion, but not sufficiently limits what code might be included. An attacker is able use a low privileges account in order to abuse this functionality and execute malicious code, load DLL libraries and executing OS commands on a host system with applications high privileges. This issue has been fixed in version 8.0.00204.0
Affected products
- Wyn Enterprise: before 8.0.00204.0 — fixed in 8.0.00204.0
How to fix
Upgrade to a fixed version: Wyn Enterprise 8.0.00204.0. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2025/02/CVE-2024-9150
- https://efigo.pl/blog/cve-2024-9150/
- https://www.wynenterprise.com/
Get alerted when CVE-2024-9150 or the next vulnerability affects your stack