What’s Vulnerable › Vulnerabilities
CVE-2024-9158: XSS
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-30 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross site scripting vulnerability exists in Nessus Network Monitor where an authenticated, privileged local attacker could inject arbitrary code into the NNM UI via the local CLI.
Affected products
- Tenable Nessus Network Monitor: before 6.5.0 — fixed in 6.5.0
How to fix
Upgrade to a fixed version: Tenable Nessus Network Monitor 6.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9158 or the next vulnerability affects your stack