What’s Vulnerable › Vulnerabilities
CVE-2024-9160: Security Misconfiguration in Forge module PEADM
- Severity: medium (CVSS 5.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-295
Description
In versions of the PEADM Forge Module prior to 3.24.0 a security misconfiguration was discovered.
Affected products
- Puppet PEADM Forge Module: from 3.8.0 before 3.24.0 — fixed in 3.24.0
How to fix
Upgrade to a fixed version: Puppet PEADM Forge Module 3.24.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9160 or the next vulnerability affects your stack