What’s Vulnerable › Vulnerabilities
CVE-2024-9163: User Interface (UI) Misrepresentation of Critical Information in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-451
Description
A business logic error in GitLab CE/EE affecting all versions starting from 12.1 prior to 17.10.7, 17.11 prior to 17.11.3 and 18.0 prior to 18.0.1 where an attacker can cause a branch name confusion in confidential MRs.
Affected products
- GitLab: from 12.1.0 before 17.10.7; from 17.11.0 before 17.11.3; 18.0.0 — fixed in 17.10.7, 17.11.3
How to fix
Upgrade to a fixed version: GitLab 17.10.7, 17.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9163 or the next vulnerability affects your stack