What’s Vulnerable › Vulnerabilities
CVE-2024-9164: Missing Authentication for Critical Function in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-11 · updated 2026-06-17
- Weakness: CWE-306
Description
An issue was discovered in GitLab EE affecting all versions starting from 12.5 prior to 17.2.9, starting from 17.3, prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows running pipelines on arbitrary branches.
Affected products
- GitLab: from 12.5.0 before 17.2.9; from 17.3.0 before 17.3.5; from 17.4.0 before 17.4.2 — fixed in 17.2.9, 17.3.5, 17.4.2
How to fix
Upgrade to a fixed version: GitLab 17.2.9, 17.3.5, 17.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9164 or the next vulnerability affects your stack