What’s Vulnerable › Vulnerabilities
CVE-2024-9170: Booster for WooCommerce <= 7.2.3 - Authenticated (ShopManager+) Stored Cross-Site Scripting via wcj_product_meta Shortcode
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Booster for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wcj_product_meta shortcode in all versions up to, and including, 7.2.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with ShopManager-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools: before 7.2.4 — fixed in 7.2.4
How to fix
Upgrade to a fixed version: pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools 7.2.4. Check the vendor advisory for mitigations.
References
- https://booster.io/changelog/
- https://booster.io/shortcodes/wcj_product_meta/
- https://plugins.trac.wordpress.org/browser/woocommerce-jetpack/trunk/includes/shortcodes/class-wcj-products-shortcodes.php#L963
- https://plugins.trac.wordpress.org/changeset/3187178/
- https://wordpress.org/plugins/woocommerce-jetpack/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0abf9705-2716-403f-9348-e43a8d8fb1d2?source=cve
Get alerted when CVE-2024-9170 or the next vulnerability affects your stack