What’s Vulnerable › Vulnerabilities
CVE-2024-9180: Vault Operators in Root Namespace May Elevate Their Privileges
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-266
Description
A privileged Vault operator with write permissions to the root namespace’s identity endpoint could escalate their own or another user’s privileges to Vault’s root policy. Fixed in Vault Community Edition 1.18.0 and Vault Enterprise 1.18.0, 1.17.7, 1.16.11, and 1.15.16.
Affected products
- HashiCorp Vault: from 1.7.7 through 1.17.7; from 1.7.7 before 1.18.0; from 1.15.0 before 1.15.16; from 1.16.0 before 1.16.11 — fixed in 1.15.16, 1.16.11, 1.18.0
- openbao: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.15.16, 1.16.11, 1.18.0; openbao 2.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9180 or the next vulnerability affects your stack