What’s Vulnerable › Vulnerabilities
CVE-2024-9182: Maspik - Advanced Spam protection < 2.1.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Maspik WordPress plugin before 2.1.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
Affected products
- yonifre Maspik – Spam blacklist: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: yonifre Maspik – Spam blacklist 2.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9182 or the next vulnerability affects your stack