What’s Vulnerable › Vulnerabilities
CVE-2024-9189: EU/UK VAT Manager for WooCommerce <= 2.12.12 - Missing Authorization
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-28 · updated 2026-06-17
- Weakness: CWE-862
Description
The EU/UK VAT Manager for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the alg_wc_eu_vat_exempt_vat_from_admin() function in all versions up to, and including, 2.12.12. This makes it possible for unauthenticated attackers to update the VAT status for any order.
Affected products
- wpcodefactory EU/UK VAT Validation Manager for WooCommerce: before 2.12.14 — fixed in 2.12.14
How to fix
Upgrade to a fixed version: wpcodefactory EU/UK VAT Validation Manager for WooCommerce 2.12.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/eu-vat-for-woocommerce/tags/2.12.12/includes/class-alg-wc-eu-vat-ajax.php#L285
- https://plugins.trac.wordpress.org/changeset/3158296/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c6db680e-1fd4-420c-98f4-2b6dc5cf6781?source=cve
Get alerted when CVE-2024-9189 or the next vulnerability affects your stack