What’s Vulnerable › Vulnerabilities
CVE-2024-9193: WHMpress <= 6.3-revision-0 - Unauthenticated Local File Inclusion to Arbitrary Options Update
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-98
Description
The WHMpress - WHMCS WordPress Integration Plugin plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 6.3-revision-0 via the whmpress_domain_search_ajax_extended_results() function. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. This makes it possible for unauthenticated attackers to update arbitrary options on the WordPress site. Utilizing the /admin/services.php file, this can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.
Affected products
- creativeon WHMpress - WHMCS WordPress Integration Plugin: before 6.3; 6.3-rev0 — fixed in 6.3
How to fix
Upgrade to a fixed version: creativeon WHMpress - WHMCS WordPress Integration Plugin 6.3. Check the vendor advisory for mitigations.
References
- https://whmpress.com/docs/change-log/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5f3b0e75-d2f0-48b7-ba33-75c4e998030e?source=cve
Get alerted when CVE-2024-9193 or the next vulnerability affects your stack