What’s Vulnerable › Vulnerabilities
CVE-2024-9194: SQL Injection in the Octopus Server REST API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-30 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Linux and Microsoft Windows Octopus Server on Windows, Linux allows SQL Injection.This issue affects Octopus Server: from 2024.1.0 before 2024.1.13038, from 2024.2.0 before 2024.2.9482, from 2024.3.0 before 2024.3.12766.
Affected products
- Octopus Deploy Octopus Server: from 2024.1.437 before 2024.1.13038; from 2024.2.101 before 2024.2.9482; from 2024.3.164 before 2024.3.12766 — fixed in 2024.1.13038, 2024.2.9482, 2024.3.12766
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2024.1.13038, 2024.2.9482, 2024.3.12766. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9194 or the next vulnerability affects your stack