What’s Vulnerable › Vulnerabilities
CVE-2024-9195: WHMPress - WHMCS Client Area <= 4.3-revision-3- Authenticated (Subscriber+) Arbitrary Options Update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-862
Description
The WHMPress - WHMCS Client Area plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the update_settings case in the /admin/ajax.php file in all versions up to, and including, 4.3-revision-3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.
Affected products
- creativeon WHMCS Client Area for WordPress by WHMpress: before 4.3; 4.3-rev1, 4.3-rev2, 4.3-rev3 — fixed in 4.3
How to fix
Upgrade to a fixed version: creativeon WHMCS Client Area for WordPress by WHMpress 4.3. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/whmcs-client-area-whmpress-addon/11218646
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c8af0c5c-3d7b-416d-9d10-6867fcf909a5?source=cve
Get alerted when CVE-2024-9195 or the next vulnerability affects your stack