What’s Vulnerable › Vulnerabilities

CVE-2024-9197

Description

A post-authentication buffer overflow vulnerability in the parameter "action" of the CGI program in Zyxel VMG3625-T50B firmware versions through V5.50(ABPM.9.2)C0 could allow an authenticated attacker with administrator privileges to cause a temporary denial of service (DoS) condition against the web management interface by sending a crafted HTTP GET request to a vulnerable device if the function ZyEE is enabled.

Affected products

How to fix

Upgrade to a fixed version: Zyxel AX7501-B0 firmware 5.17\(abpc.5.3\)c0; Zyxel AX7501-B1 firmware 5.17\(abpc.5.3\)c0; Zyxel DX3300-T0 firmware 5.50\(aby.5.4\)c0; Zyxel DX3300-T1 firmware 5.50\(aby.5.4\)c0; Zyxel DX3301-T0 firmware 5.50\(aby.5.4\)c0; Zyxel Dx4510-B0 Firmware 5.17\(abyl.8\)c0; Zyxel Dx4510-B1 Firmware 5.17\(abyl.8\)c0; Zyxel DX5401-B0 firmware 5.17\(abyo.6.4\)c0; Zyxel Dx5401-B1 Firmware 5.17\(abyo.6.4\)c0; Zyxel Ee6510-10 Firmware 5.19\(acjq.1\)c0; Zyxel Emg3525-T50B Firmware 5.50\(abpm.9.3\)c0; Zyxel Emg5523-T50B Firmware 5.50\(abpm.9.3\)c0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-9197 or the next vulnerability affects your stack