What’s Vulnerable › Vulnerabilities
CVE-2024-9204: Smart Custom 404 Error Page <= 11.4.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Smart Custom 404 Error Page plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via $_SERVER['REQUEST_URI'] in all versions up to, and including, 11.4.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- nerdpressteam Smart Custom 404 Error Page: before 11.4.8 — fixed in 11.4.8
How to fix
Upgrade to a fixed version: nerdpressteam Smart Custom 404 Error Page 11.4.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/404page/tags/11.4.7/functions.php#L112
- https://plugins.trac.wordpress.org/browser/404page/tags/11.4.7/inc/class-404page.php#L1227
- https://plugins.trac.wordpress.org/changeset/3161639/#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/93928123-c90d-4bbb-b51d-33e809867b79?source=cve
Get alerted when CVE-2024-9204 or the next vulnerability affects your stack