What’s Vulnerable › Vulnerabilities
CVE-2024-9205: Maximum Products per User for WooCommerce <= 4.2.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Maximum Products per User for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 4.2.8. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- wpcodefactory Maximum Products per User for WooCommerce: before 4.2.9 — fixed in 4.2.9
How to fix
Upgrade to a fixed version: wpcodefactory Maximum Products per User for WooCommerce 4.2.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/maximum-products-per-user-for-woocommerce/tags/4.2.8/includes/class-alg-wc-mppu-users.php#L836
- https://plugins.trac.wordpress.org/changeset/3164534/maximum-products-per-user-for-woocommerce/tags/4.2.9/includes/class-alg-wc-mppu-users.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/140c0d22-dc26-4100-a5c0-a2f8a6f98d97?source=cve
Get alerted when CVE-2024-9205 or the next vulnerability affects your stack