What’s Vulnerable › Vulnerabilities
CVE-2024-9223: WPDash Notes <= 1.3.5 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-23 · updated 2026-06-17
- Weakness: CWE-862
Description
The WPDash Notes plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'wp_ajax_post_it_list_comment' function in all versions up to, and including, 1.3.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to view comments on any post, including private and password protected posts, and pending and draft posts if they were previously published. The vulnerability was partially patched in version 1.3.5.
Affected products
- wpformation WPDash Notes: through 1.3.5
References
- https://plugins.trac.wordpress.org/browser/wpdash-notes/trunk/classes/plugin.php#L210
- https://www.wordfence.com/threat-intel/vulnerabilities/id/58f048e5-f4be-4452-8fed-16871f4020b6?source=cve
Get alerted when CVE-2024-9223 or the next vulnerability affects your stack