What’s Vulnerable › Vulnerabilities
CVE-2024-9224: Hello World <= 2.1.1 - Authenticated (Subscriber+) Arbitrary File Read
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-22
Description
The Hello World plugin for WordPress is vulnerable to Arbitrary File Reading in all versions up to, and including, 2.1.1 via the hello_world_lyric() function. This makes it possible for authenticated attackers, with subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
Affected products
- kau-boy Hello World: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: kau-boy Hello World 2.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/hello-world/tags/2.1.1/hello-world.php#L113
- https://plugins.trac.wordpress.org/browser/hello-world/tags/2.1.1/hello-world.php#L35
- https://plugins.trac.wordpress.org/changeset/3161773/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2f58df1f-66f7-4e3d-af6d-08174653a2ad?source=cve
Get alerted when CVE-2024-9224 or the next vulnerability affects your stack