What’s Vulnerable › Vulnerabilities
CVE-2024-9228: Loggedin – Limit Active Logins <= 1.3.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Loggedin – Limit Active Logins plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.3.1. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This is only exploitable when the leave a review notice is present.
Affected products
- joelcj91 Loggedin – Limit Concurrent Sessions: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: joelcj91 Loggedin – Limit Concurrent Sessions 1.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/loggedin/tags/1.3.1/includes/class-loggedin-admin.php#L255
- https://plugins.trac.wordpress.org/changeset/3161008/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/59707c64-a34c-45bc-bbbe-d447fe2ca6ab?source=cve
Get alerted when CVE-2024-9228 or the next vulnerability affects your stack