What’s Vulnerable › Vulnerabilities
CVE-2024-9231: WP-Members Membership Plugin <= 3.4.9.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.4.9.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- cbutlerjr WP-Members Membership Plugin: before 3.4.9.6 — fixed in 3.4.9.6
How to fix
Upgrade to a fixed version: cbutlerjr WP-Members Membership Plugin 3.4.9.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-members/tags/3.4.9.5/includes/class-wp-members-forms.php#L2198
- https://plugins.trac.wordpress.org/browser/wp-members/tags/3.4.9.5/includes/class-wp-members.php#L1960
- https://plugins.trac.wordpress.org/changeset/3172354/wp-members/trunk/includes/class-wp-members-forms.php?contextall=1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d59e599-59da-4c03-b71f-d00a078b2442?source=cve
Get alerted when CVE-2024-9231 or the next vulnerability affects your stack