What’s Vulnerable › Vulnerabilities
CVE-2024-9237: Fish and Ships <= 1.5.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Fish and Ships – Most flexible shipping table rate. A WooCommerce shipping rate plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.5.9. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Wp-Centrics Fish And Ships: before 1.6 — fixed in 1.6
How to fix
Upgrade to a fixed version: Wp-Centrics Fish And Ships 1.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/fish-and-ships/tags/1.5.9/includes/wizard.php#L226
- https://plugins.trac.wordpress.org/browser/fish-and-ships/tags/1.5.9/includes/wizard.php#L369
- https://plugins.trac.wordpress.org/browser/fish-and-ships/tags/1.5.9/includes/wizard.php#L479
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3161229%40fish-and-ships&new=3161229%40fish-and-ships&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ceaf64d6-9872-4572-807e-7fce76edee57?source=cve
Get alerted when CVE-2024-9237 or the next vulnerability affects your stack