What’s Vulnerable › Vulnerabilities
CVE-2024-9238: AVIF & SVG Uploader <= 1.1.0 - Author+ Stored XSS via SVG Uplaod
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The AVIF Uploader WordPress plugin before 1.1.1 does not sanitise uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads.
Affected products
- grandplugins AVIF Uploader: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: grandplugins AVIF Uploader 1.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9238 or the next vulnerability affects your stack