What’s Vulnerable › Vulnerabilities
CVE-2024-9239: Booster for WooCommerce <= 7.2.3 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Booster for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 7.2.3. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools: before 7.2.4 — fixed in 7.2.4
How to fix
Upgrade to a fixed version: pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools 7.2.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woocommerce-jetpack/tags/7.2.3/includes/settings/wcj-settings-pdf-invoicing-advanced.php#L53
- https://plugins.trac.wordpress.org/browser/woocommerce-jetpack/tags/7.2.3/includes/tools/class-wcj-order-statuses-tool.php#L319
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3187178%40woocommerce-jetpack&new=3187178%40woocommerce-jetpack&sfp_email=&sfph_mail=#file5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c4665b87-e1f8-4a73-b6d6-1d5c14067b3a?source=cve
Get alerted when CVE-2024-9239 or the next vulnerability affects your stack